Spatial Edge Server failed to start


A few weeks ago i started with the Spatial Edge Server and the Spatial Toolbox App.
I completed a few tutorials (until Creating a simple tool) and they worked fine.

Now, i wanted to make the other tutorials and the Spatial Edge Server does not start anymore. (I did not changed a thing in the weeks between).

The error message after typing npm start in the vuforia-spatial-edge-server is:

` 2020-10-31T15:14:55.819Z - debug: '**** DIR: ’ 'C:\Users\break\vst-edge-server
2020-10-31T15:14:56.996Z - debug: ‘Starting the Server’
2020-10-31T15:14:56.997Z - debug: 'Initialize System: ’
2020-10-31T15:14:56.997Z - debug: ‘Loading Hardware interfaces’
2020-10-31T15:14:56.998Z - debug: ‘Done’
2020-10-31T15:14:56.998Z - debug: ‘Loading Objects’
2020-10-31T15:14:57.000Z - debug: ‘Enter loadObjects’
2020-10-31T15:14:57.006Z - debug: ‘TempFolderName: book_R41wetvh029’
2020-10-31T15:14:57.008Z - debug: ‘I found objects that I want to add’
2020-10-31T15:14:57.022Z - debug: ‘TempFolderName: Packung_ha5o7t9wf4r’
2020-10-31T15:14:57.023Z - debug: ‘I found objects that I want to add’
2020-10-31T15:14:57.025Z - debug: ‘TempFolderName: Spieluhr’
2020-10-31T15:14:57.031Z - debug: ‘I found objects that I want to add’
2020-10-31T15:14:57.036Z - debug: ‘TempFolderName: _WORLD_test_X3k6d5b055j’
2020-10-31T15:14:57.037Z - debug: ‘I found objects that I want to add’
2020-10-31T15:14:57.039Z - debug: ‘object is all cleared’
for (var key in objects[objectID].frames[objectID].nodes) {

TypeError: Cannot read property ‘nodes’ of undefined
at Object.exports.clearObject (C:\Users\break\OneDrive\Dokumente\vuforia-spatial-edge-server\libraries\hardwareInterfaces.js:145:60)
at Object.exports.reset (C:\Users\break\OneDrive\Dokumente\vuforia-spatial-edge-server\libraries\hardwareInterfaces.js:756:19)
at loadObjects (C:\Users\break\OneDrive\Dokumente\vuforia-spatial-edge-server\server.js:759:17)
at Object. (C:\Users\break\OneDrive\Dokumente\vuforia-spatial-edge-server\server.js:618:1)
at Module._compile (internal/modules/cjs/loader.js:1137:30)
at Object.Module._extensions…js (internal/modules/cjs/loader.js:1157:10)
at Module.load (internal/modules/cjs/loader.js:985:32)
at Function.Module._load (internal/modules/cjs/loader.js:878:14)
at Function.executeUserEntryPoint [as runMain] (internal/modules/run_main.js:71:12)
at internal/main/run_main_module.js:17:47

What i did to track down possible errors was to take out every .index -file that is stored in my Spatialtoolbox/Object/interface folder. After deleting the interface folders, the server started again.
However, the content of these files is copied from the tutorials and they worked fine previously.

What can i do?


Hi @MattMat thank you for sharing this bug.

  1. This is certainly an error that we should catch before it occurs.
  2. I believe the cause of this error is that there is something broken with your objects. Objects are stored in documents > spatialToolbox > [NameOfYourObject] > .identity > object.json
    If your object exists but this file is missing or broken, you could potentially get such an error.

Could you reproduce the error and send me a copy of your object file? We will make sure to fix this issue.

Hi Valentin.

I can not reproduce the error. It just worked the next time i tried it.


That sounds good! Keep us updated in case the problem shows up again.