Unable to connect Kepware Interface

Hi All,

Have some issue while working on Kepware interface. Iam getting following error. need advise. Thanks in advance for your support.

I have setup IOT Gateway on KEPServerEX which is on my laptop itself and could able to see it on simple rest client (webpage)

simple webpage.PNG

please advise. Thanks

Regards,
Abdulla

Hi @Abdulla did you made any changed to the kepware interface? I can see that the formatting of your kepware configuration is different from what it should be. You are also missing the Port input field. I believe that that this is the reason why you can not connect to your kepware server. Your missing the right port selection.

No, initially i used index.js from the github repository. I was having the same issue. Then, later contacting @ben, he shared another file, but same issue even after using the Ben’s index.js.

I can’t attach the file i am using here as it does not allow any file other than media files like jpg, png, mp4

If you would like have quick remote session if that helps faster diagnosis, it would be really great help.

Please advise. Thanks

Hi Abdulla,
just to make sure that the core unchanged system is working on your side.

Would you mind installing the edge server into a new folder on your computer using the step by step instructions from https://github.com/ptcrealitylab/vuforia-spatial-edge-server.

Then try to connect to Kepware with this fresh install of the server. If we can establish that our install works on your machine, then we can circle down what issues your changes might produced.

Hi Valentin,

Thanks for suggestion and support.

As suggested, i did fresh installation into different location and could able to successfully install and also notice additional settings on the edge server related to Kepware interface.

I could not noticed any error this time . However, I had to set name and framename as well instead of leaving to default ‘0’ value.’ I have to check this with app to confirm if this is working as expected.

I will update here once i could get through .

Thanks again for your support and patience in responding :slight_smile: .

[image]