Initializing AR Tracking

Hi everyone, my name is jeremy and I am new there.

I try to use this tutorial : GitHub - ptcrealitylab/Vuforia-Spatial-Toolbox-Virtualizer.

I have followed all the steps, I launch Unity, I can see in the scene the feedback of my Azure kinect, but when I went to localhost:8081, I have this screen :

I have created an object and I have the IP, as you can see, and I don’t know what to do next to have the feedback in the localhost:8081. If you can help me with that, it will be great.

Thank you :slight_smile:

Hi @Jeremy - welcome to the forum! You are experiencing a bug resulting from a new feature that we just pushed to the vuforia-spatial-toolbox-userinterface codebase but the vuforia-spatial-remote-operator-addon hasn’t been updated to account for this yet. I’ll push the fix to the addon codebase as soon as I can and let you know when to update it.

Ok @Jeremy I believe your problem will be solved if you update your vuforia-spatial-remote-operator-addon to the latest version.

This should make the “Initializing AR Tracking” screen disappear.

The remaining steps to make everything load and appear correctly are explained in this thread: No picture from virtualizer appears in webpage of port 8081

In short, you need to click the IP address of your Virtualizer in that upper left box to select it, and then you need to click on the gear icon to open the settings menu, and type in your IP address (without any port numbers) into the “Primary Virtualizer IP” field.

Hi Ben,

Thank you a lot for your answer, I will take a look about that :slight_smile: