Detecting Model Targets issues

Hi everyone,

I’m trying to detect and track an object with a Model Target attached to it.
I generated the dataset (but not trained, similar to what @ben demonstrated with his Nintendo Switch), and then upload it on the localhost page.
I experienced inconsistent behaviour while trying to establish tracking :

  • Sometimes it’s not recognized at all, and I can see an error
    “Error: ENOENT: no such file or directory, stat ‘C:\Users\fgermain\Documents\spatialToolbox\LegoCar\.identity\target\target.xml’”

  • Sometimes it does seems to be recognized (message on the console, and the AR interface flashes), but the interface is not displayed

  • When recognized, it can be so exactly twice (if you look elsewhere and get back to it) and not anymore after that.

I recorded an example of such a behaviour in the following video (displaying both the camera view and the console) :

Windows 10, fresh install from today, up-to-date Toolbox app on iPhone.

@ptc-fgermain I believe there is an issue with the web uploader not working reliable with multiple files selected at the same time. If you upload each of these three files individually you might not run into this issue. Can you test this assumption? If you look at the log, the xml file is not showing up after the upload step.

@valentin I tried recreating the object and adding the files to the target one by one : while I don’t get the “xml missing” error, I experience the same behavior as documented in the video (from the 3:10 mark): target is recognized, the interface flashes but is not displayed, if I move away and come back the target is recognized once more, but after that, if I move away again, it won’t be recognized anymore.

@ptc-fgermain I just tested the model targets and there seems to be no error.

  1. Make sure that the name of your model target is identical to the server UI provided name
  2. Make sure that you chose the right scale (millimeter)
  3. Do not save a Guide View. Guide View does not work well with the distributed multi object spatial toolbox, since the toolbox expects to discover a multitude of objects. The Guide View is for mainly for a single object application.
  4. Only create a single Advance View
  5. Create Database (Make sure that only a single target is saved with your dataset

This should generate a working model target.
Let me know if this helped so that we can mark it as resolved.

@valentin Thanks for testing it out. I tried again on my side and found the issue: I didn’t rename the MT ! I thought it was only for Image Targets, somehow… As my Area Target works even tho the Dataset and target name in the Server UI are not the same…

Now it works as it should. I do have a couple of questions tho:

  1. Is there any best practices to get the interface icon correctly placed relatively to the object tracked by MT ? Right now the blue square is vertical and offset from the center.
  2. Is there any value in generating a Model Target Dataset and train it, to allow recognition from 360° ? Is it supported ?