Unable to connect Boost to the server


I was playing with the LEGO Boost Robot addon. So far everything on the tutorial seemed to work great but with the Boost tutorial I am having trouble connecting the Boost to the Server. Looks like I am missing some crucial step. Here is what I have

  1. Bluetooth on my phone and mac are on and accepting connections.
  2. I run the server and press the green button, nothing happens.
  3. I created my target using Vuforia Developer Portal as instructed in the tutorial and my phone is able to detect the target.
  4. I can see the KineticAR object on Found Objects

Any suggestions would be highly appreciated.


How do I set enableMIRConnection to true? Any idea? https://spatialtoolbox.vuforia.com/docs/vuforia-spatial-robotic-addon/interfaces/lego-boost/README

What kind of logs do you see in the terminal?
I see following when the green button on my lego is pressed.

2020-05-26T10:45:34.843Z - debug: ‘Found the following Lego Move Hub: Move Hub with UUID 1abcde58809f4395bcdd3c9a07babcde’
2020-05-26T10:45:34.844Z - debug: ‘Connected to: Move Hub’
2020-05-26T10:45:34.844Z - debug: ‘Starting Setup for 1abcde58809f4395bcdd3c9a07babcde’
2020-05-26T10:45:34.932Z - debug: ‘device initialisation’
2020-05-26T10:45:34.933Z - debug: ‘LEGO-BOOST: I found a device with uuid: 1abcde58809f4395bcdd3c9a07babcde’
2020-05-26T10:45:34.933Z - debug: ‘pushSettingsToGui for lego-boost’
2020-05-26T10:45:35.112Z - debug: ‘activated tacho Motor on port 0 @ 1abcde58809f4395bcdd3c9a07babcde’
2020-05-26T10:45:35.112Z - debug: ‘activated tacho Motor on port 1 @ 1abcde58809f4395bcdd3c9a07babcde’
2020-05-26T10:45:35.113Z - debug: ‘activated vision sensor on port 2 @ 1abcde58809f4395bcdd3c9a07babcde’
2020-05-26T10:45:35.113Z - debug: ‘activated tacho Motor on port 3 @ 1abcde58809f4395bcdd3c9a07babcde’
2020-05-26T10:45:35.113Z - debug: ‘activated tacho Motor on port 16 @ 1abcde58809f4395bcdd3c9a07babcde’
2020-05-26T10:45:35.125Z - debug: ‘activated LED Light on port 50 @ 1abcde58809f4395bcdd3c9a07babcde’
2020-05-26T10:45:35.126Z - debug: ‘activated tilt sensor on port 58 @ 1abcde58809f4395bcdd3c9a07babcde’
2020-05-26T10:45:35.140Z - debug: ‘LEGO-BOOST: PORT: 0 — motorRotation.absoluteDeg: -1’
2020-05-26T10:45:35.154Z - debug: ‘LEGO-BOOST: PORT: 1 — motorRotation.absoluteDeg: -1’
2020-05-26T10:45:35.156Z - debug: ‘LEGO-BOOST: PORT: 3 — motorRotation.absoluteDeg: 1’
2020-05-26T10:45:35.189Z - debug: ‘LEGO-BOOST: PORT: 16 — motorRotation.absoluteDeg: -1’
2020-05-26T10:45:35.433Z - debug: ‘activated Battery’

Hi @milandahal213! welcome to the forum!

The current npm package for the boost (https://www.npmjs.com/package/wedoboostpoweredup), has some code that needs to be updated as per the last modifications to the Lego Boost firmware.

We are working on it and will soon post and update in the next day or two.

Unfortunately no. The terminal doesn’t look anything like that. Thank you for sharing your screenshot, though.

Sounds good. Thank you @anna! Looking forward to the update.

@milandahal213 we have updated the wedoboostpoweredup npm package. Could you try updating it and see if it connects now?

Hi @anna I deleted everything and started from scratch. But I do not yet have any success. The Boost doesn’t still connect to the computer. I am running MacOS Catalina, 10.15.2. Do you think that might be the issue?

Just to make sure, the Boost should automatically connect (after I press the green button) to my computer and I should see the Red Off turn into Green On for isRobotConnected. Right? Is there a preferred sequence of steps or wait times?

@milandahal213 It seems like Lego made a short change to there firmware where we had to wait for a certain message on the new firmware that was irrelevant for the old firmware.

It now looks like that Lego went back to what it was before. So the last update on the wedoboostpowerup npm repository changed that back.

What you need to do:

  1. Update the robotic addon via npm to the latest versions.
  2. Update your Boost to the latest Firmware via the Lego app

Also make sure that no headphones and so on are connected to your computer, because sometimes that prevents the bluetooth LE from working rightfully.

Hi @valentin. I did as you suggested and it did not work. I even tried it on a different mac. I am starting to believe it is the latest OS that is the problem. Have you tested this on Catalina 10.15? We had similar issues with bluetooth on EV3 too.

Just confirmed with @milandahal213 that the latest update (2.1.3) to https://www.npmjs.com/package/wedoboostpoweredup fixed the problem.

We just updated the package file form the robotic add-on, it should install 2.1.3 now and therefore the fix.

1 Like

@milandahal213 we found a ton more issues with the boost interface on different systems. The latest server and add-on versions should fix that: