Device can't find edge server

Hi – I’m having trouble connecting my device to the server. The Edge server is running, but the toolbox app can’t find the server running on my network. Both devices are on the same Wi-Fi network, and when I start the app the server responds (below), but the Toolbox App > Settings > Found Servers field is empty, and my image target isn’t recognized. Any ideas on what might be wrong?

2020-12-18T13:54:00.572Z - debug: 'Starting the Server'
2020-12-18T13:54:00.573Z - debug: 'Initialize System: '
2020-12-18T13:54:00.573Z - debug: 'Loading Hardware interfaces'
2020-12-18T13:54:00.573Z - debug: 'Done'
2020-12-18T13:54:00.574Z - debug: 'Loading Objects'
2020-12-18T13:54:00.575Z - debug: 'Enter loadObjects'
2020-12-18T13:54:00.579Z - debug: 'TempFolderName: 5480PLC_ka24oas2l5i'
2020-12-18T13:54:00.579Z - debug: 'I found objects that I want to add'
2020-12-18T13:54:00.580Z - debug: 'added object 5480PLC_ka24oas2l5i to scene graph (to parent: ROOT)'
2020-12-18T13:54:00.580Z - debug: 'added frame 5480PLC_ka24oas2l5ionoff to scene graph (to parent: 5480PLC_ka24oas2l5i)'
2020-12-18T13:54:00.586Z - debug: 'object is all cleared'
2020-12-18T13:54:00.587Z - debug: 'hardwareInterfaces.reset calling reset callbacks'
2020-12-18T13:54:00.588Z - debug: 'Done loading objects'
2020-12-18T13:54:00.588Z - debug: 'Done loading world object'
2020-12-18T13:54:00.589Z - debug: 'creating beat for object: 5480PLC_ka24oas2l5i'
2020-12-18T13:54:00.590Z - debug: 'with version number: 322'
2020-12-18T13:54:00.618Z - debug: ' started'
2020-12-18T13:54:00.619Z - debug: 'started'
2020-12-18T13:54:00.624Z - debug: 'Add reset listener'
2020-12-18T13:54:00.624Z - debug: 'setup kepware'
2020-12-18T13:54:00.625Z - debug: 'tags info saved in settings.json: ' 0
2020-12-18T13:54:00.630Z - debug: 'ready to start internal servers'
2020-12-18T13:54:00.630Z - debug: 'object is all cleared'
2020-12-18T13:54:00.631Z - debug: 'hardwareInterfaces.reset calling reset callbacks'
2020-12-18T13:54:00.632Z - debug: 'reset kepware'
2020-12-18T13:54:00.632Z - debug: 'setup kepware'
2020-12-18T13:54:00.633Z - debug: 'tags info saved in settings.json: ' 0
2020-12-18T13:54:00.634Z - debug: 'found 1 enabled hardware interfaces'
2020-12-18T13:54:00.634Z - debug: 'starting internal Server.'
2020-12-18T13:54:00.635Z - debug: 'Reality Server server.js process is running with PID 8712'
2020-12-18T13:54:00.652Z - debug: 'webserver + is listening on port' 8080
2020-12-18T13:54:00.653Z - debug: 'UDP listening on port: 52316'
2020-12-18T13:54:00.653Z - debug: 'server initialized. Every initialization from now on should come from interface addons only'
2020-12-18T13:54:21.031Z - debug: 'ping'
2020-12-18T13:54:21.032Z - debug: 'creating beat for object: 5480PLC_ka24oas2l5i'
2020-12-18T13:54:21.032Z - debug: 'with version number: 322'
2020-12-18T13:54:21.533Z - debug: 'ping'
2020-12-18T13:54:21.533Z - debug: 'creating beat for object: 5480PLC_ka24oas2l5i'
2020-12-18T13:54:21.535Z - debug: 'with version number: 322'
2020-12-18T13:54:21.953Z - debug: 'ping'
2020-12-18T13:54:21.953Z - debug: 'creating beat for object: 5480PLC_ka24oas2l5i'
2020-12-18T13:54:21.954Z - debug: 'with version number: 322'

Hi @ptc-pz , I can think of a couple reasons why this could be happening.

  1. It’s possible that your Edge Server is using a network interface that isn’t allowing for communication with the toolbox apps in your network. You can change this on your server’s web interface, right underneath the version and IP address at the top of the screen. In my screenshot I only have one option (en0) but you may have some other buttons next to this green button that you can select to restart your server with a different network interface.

  1. If you are running your Edge Server in a corporate or university network they often disable a network feature that we rely on for auto-discovery of clients and servers. You can get around this by directly entering your Edge Server’s IP address in your Spatial Toolbox’s menu (Settings -> Develop -> Discovery Server) (as explained in this post and the following screenshot). This will directly connect to this one edge server.

Let me know if either of these methods work for you!

Hi Ben,

Thanks for the quick reply. The second method–entering the IP of the server–worked for me (I had tried that before but neglected to include the port number). I’m on a home wifi network (Verizon Fios). Any idea what setting I might be able to change on my network to enable discovery?